manager.propertyme.com slowness

Incident Report for PropertyMe

Resolved

This incident has been resolved.
Posted Sep 19, 2024 - 21:39 AEST

Identified

Users are experiencing slowness and queuing of messages with manager.propertyme.com. We have identified the issue and are working to resolve it as quickly as possible. Stay with us, and we will have things back to normal operation in a short while.
Posted Sep 19, 2024 - 17:22 AEST