PropertyMe is currently experiencing degraded performance.
Incident Report for PropertyMe
Resolved
Performance degradation has now been resolved and we will continue to monitor.
Posted Aug 03, 2020 - 10:05 AEST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2020 - 10:02 AEST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2020 - 09:54 AEST
Update
Users are experiencing slowness accessing and using all features in the PropertyMe app. We are working to understand the full cause and restore the service as quickly as possible. More updates to follow shortly.
Posted Aug 03, 2020 - 09:36 AEST
Investigating
We are currently investigating this issue.
Posted Aug 03, 2020 - 09:36 AEST
This incident affected: PropertyMe.